Latency impacting our US customers
Incident Report for Interact
Resolved
Full service has been restored.
Posted Jul 22, 2019 - 08:37 UTC
Monitoring
Latency levels have returned to normal and engineers continue to monitor.
Posted Jul 22, 2019 - 08:36 UTC
Investigating
We are currently investigating some traffic spikes with increased latency for a subset of users on our US pods.
Posted Jul 22, 2019 - 08:35 UTC
This incident affected: North America / HIPAA Public Cloud.