Service Disruption impacting our EU customers
Incident Report for Interact
Resolved
This incident has been resolved.
Posted Dec 11, 2018 - 11:14 UTC
Investigating
Investigating - Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and service disruption across all EU customers.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted Dec 11, 2018 - 11:09 UTC
This incident affected: EMEA Public Cloud.