Service Disruption impacting our EU customers
Incident Report for Interact
Resolved
This incident has now been resolved, and service is back to normal.
Posted 3 months ago. Jun 20, 2019 - 15:36 UTC
Monitoring
Interact Engineers have corrected the problem and service is operational. Engineers will continue to monitor and investigate further

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted 3 months ago. Jun 20, 2019 - 12:34 UTC
Investigating
Investigating - Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness across all EU customers.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted 3 months ago. Jun 20, 2019 - 12:04 UTC
This incident affected: Europe Public Cloud 1 and Europe Public Cloud 2.