Service Disruption impacting a subset of our EU customers
Incident Report for Interact
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 13, 2018 - 10:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Nov 13, 2018 - 10:02 UTC
Investigating
Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and service disruption across a subset of EU customers.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted about 1 month ago. Nov 13, 2018 - 09:53 UTC