US users may experience delays in content being updated
Incident Report for Interact
Resolved
This incident has now been resolved, and processing of items has now been restored to normal service.
Posted about 1 month ago. Nov 13, 2018 - 17:25 UTC
Investigating
Interact Engineers are currently investigating alerts of delays in content being updated for our US customer base.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted about 1 month ago. Nov 13, 2018 - 17:07 UTC
This incident affected: United States Public Cloud, HIPAA Cloud, and United States Public Cloud - Mobile app and API.