Service Disruption impacting our EU customers
Incident Report for Interact
Resolved
This incident has been resolved.
Posted 8 months ago. Jan 14, 2019 - 09:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 months ago. Jan 14, 2019 - 08:53 UTC
Investigating
Investigating - Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and service disruption across all EU customers.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologise for the inconvenience.

Interact Support
Tel: 0161 9273223
Posted 8 months ago. Jan 14, 2019 - 08:49 UTC