Latency issues impacting a subset of EU Customers

Incident Report for Interact

Resolved

This incident has been resolved.
Posted Oct 26, 2022 - 09:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 26, 2022 - 08:51 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 26, 2022 - 08:47 UTC

Investigating

Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and intermittent service disruption across all EU customers.
Posted Oct 26, 2022 - 08:42 UTC
This incident affected: EMEA Public Cloud.