Latency issues impacting a subset of EU Customers
Incident Report for Interact
Postmortem

On the morning of May 10th, 2021, during routine scaling, customers reported increased latency as the Interact infrastructure became less responsive to incoming requests due to high traffic volume. While our Cloud Engineers rotated in new servers to handle increased traffic, customers were reporting a positive increase in response and load times. A subset of customers still experienced issues; therefore, our Cloud Engineers restarted a specific DB server impacted while the connections were reset. A spot-check of client environments was subsequently performed and verified that the platform was running successfully and marked the incident as full resolved.

Resolution:

Our Cloud Engineering team rotated new web servers while restarting a DB server.

Remediation:

Current work is being done to increase cloud infrastructure to improve site reliability. Moreover, Interact has recently hired additional resources to help scalability and to improve overall site performance.

Posted May 11, 2021 - 11:35 UTC

Resolved
We sincerely apologise for the recent disruption to your Interact site. Our engineers have now fully resolved this issue and a full post mortem will be published to our status page as soon as our investigations are complete.
Posted May 10, 2021 - 10:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2021 - 10:16 UTC
Update
We apologise for the disruption this is causing to you and your users. We are actively working on this issue and aim to get this resolved as soon as possible.
Posted May 10, 2021 - 09:25 UTC
Identified
The issue has been identified and our team are working on implementing a fix as soon as possible.
Posted May 10, 2021 - 08:49 UTC
Investigating
Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and intermittent service disruption across all EU customers.
Posted May 10, 2021 - 08:23 UTC
This incident affected: EMEA Public Cloud.