Latency issues impacting a subset of EU Customers
Incident Report for Interact
Postmortem

Root Cause Analysis

On the morning of May 4th, 2021, during routine scaling, Interact servers experienced latency due to an abnormal increase in traffic. The infrastructure was unable to scale at a satisfactory rate, which resulted in flooded request queues that were unable to recover in a timely fashion even after reaching full capacity. A similar situation occurred on the morning of May 5th when traffic demands again overloaded servers during active scaling.

Resolution

To fix both of these issues, our engineering team restarted the impacted servers and services returned to normal.

Remediation

Interact engineers are adjusting the infrastructure to capably serve a higher volume of traffic through pre-provisioning servers ahead of scaling and ensuring that queues are self-cleaned in the event of long-running requests or overloaded queues.

Posted May 06, 2021 - 07:46 UTC

Resolved
Our team have now resolved this incident and a full post mortem will be published as soon as our investigations are complete.

We sincerely apologise for any disruption this has caused to you and your intranet users.
Posted May 04, 2021 - 10:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 09:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2021 - 09:11 UTC
Investigating
Interact Engineers are currently investigating issues within the EU of higher than normal latency which is causing slowness and intermittent service disruption across all EU customers.
Posted May 04, 2021 - 08:37 UTC
This incident affected: EMEA Public Cloud.