Site Outages

Incident Report for Interact

Resolved

This issue has been resolved and site performance is operating at normal levels. We will continue to monitor to ensure ongoing stability. Thank you for your patience.
Posted Jan 13, 2026 - 15:37 UTC

Monitoring

We are currently seeing site performance operating at normal levels. The team continues to monitor closely and is still investigating the root cause of the earlier issue. We’ll provide further updates as more information becomes available.
Posted Jan 13, 2026 - 15:19 UTC

Investigating

Some customers may be experiencing intermittent site outages. The team is currently investigating the issue and working to identify the cause. We’ll provide further updates as more information becomes available.
Posted Jan 13, 2026 - 14:52 UTC
This incident affected: North America / HIPAA Public Cloud.