Service Disruption impacting our US customers
Incident Report for Interact
Resolved
This incident has now been resolved and normal service for affected customers has resumed
Posted Apr 12, 2022 - 22:25 UTC
Monitoring
The issue has been identified and resolved. Engineers will continue to monitor
Posted Apr 12, 2022 - 22:09 UTC
Investigating
We are aware of issues affecting some customers in our US pod. Engineers are currently investigating
Posted Apr 12, 2022 - 21:56 UTC
This incident affected: North America / HIPAA Public Cloud.