US Technical Support Phone Number is down
Incident Report for Interact
Resolved
The US Technical Support phone line has been restored.
Posted Oct 07, 2021 - 15:52 UTC
Identified
The issue with our North American Technical Support phone number has been identified; however, the fix to the issue may take a while to resolve. Please continue to use this number: 646-969-3388.
Posted Oct 07, 2021 - 14:25 UTC
Investigating
Our primary published phone number for US Technical Support is currently down. You can call us at this number: 646-969-3388. We expect to restore the existing phone number, but you can use this number now and in the future as both numbers are able to reach the same destination.
Posted Oct 07, 2021 - 11:59 UTC
This incident affected: North America / HIPAA Public Cloud.