Service Disruption impacting our US customers
Incident Report for Interact
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 16:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2022 - 15:40 UTC
Investigating
Interact Engineers are currently investigating issues within the US of higher than normal latency which is causing slowness and service disruption across a subset of US customers.

Engineers are working on a resolution at highest priority and will continue to update this page with updates.

We apologize for the inconvenience.
Posted Dec 15, 2022 - 14:02 UTC
This incident affected: North America / HIPAA Public Cloud.