Interact

Partial disruption to US hosted sites

Incident Report for Interact

Resolved

The issue affecting US-hosted sites has been resolved and all services are operating normally.

Our engineering team has completed monitoring and confirmed that service has remained stable. We appreciate your patience while we worked to resolve this issue.
Posted Jun 23, 2026 - 18:39 UTC

Monitoring

Our engineering team is continuing to monitor the environment to ensure service stability and confirm that the issue has been fully resolved. We will provide a final update once monitoring is complete.
Posted Jun 23, 2026 - 18:01 UTC

Investigating

We are currently investigating reports of issues affecting some US-hosted sites. Users may experience intermittent access problems, degraded performance, or unexpected errors.

Our engineering team is actively investigating the cause and working to restore normal service as quickly as possible. We will provide further updates as more information becomes available.
Posted Jun 23, 2026 - 17:44 UTC
This incident affected: North America / HIPAA Public Cloud.